Setup jshint for Ext JS?

I'm using Ext JS 4.1 and I'd like to enable jshint for my project, but it says "Ext" undefined.  Is there a way to configure jshint in WebStorm 4.0 to know about Ext JS?

4 comments
Comment actions Permalink

Type

/*global Ext:false */



into the first line in your extjs file, to exclude the Ext scope.
the missing blank between the /* and the "global" is important.

I use the same config for codekit and it works for me.
0
Comment actions Permalink

Thanks, this works.  Although, it would be nice to be able to set a config for my project to exclude the Ext scope, instead of having to modify every file, but I'm happy to have a solution.

0
Comment actions Permalink

it would be the best, if phpStorm has also a option to define a list of namespaces to exclude them from jsHint.
that makes sense, if you work with many files in js and you have some global functions or own namespaces.
otherwise you must define all of these global functions / custom namespaces in every file.

0

Please sign in to leave a comment.