Phpstorm 4.0.1 Config not loading from PHPstorm 3.0

I just installed 4.0.1.  When it comes up the first time, it asks if I want to
use the config from 3.0, but it guesses the wrong place to load it from.  Where is the correct location?

I shut it down, but now it doesn't ask again.  How do I do it a second time?

m

7 comments
Comment actions Permalink

If you work under Windows 7 look at "c:\Users\username\.WebIde10" ;)

0
Comment actions Permalink

I had the same issue on Mac OS 10.7.3. Jetbrains4 said there was no previous installation in Applicationss. There is.   

There's no point in me upgrading if I can't import my settings.

0
Comment actions Permalink

Hi Mark,

You ALWAYS can export settings (File | Export Settings..) from old version and import them into new one (File | Import Settings..). The fact that this particular dialog does not suggest correct path does not mean that you cannot import your settings.

In any case -- check this thread -- it has all info necessary: http://devnet.jetbrains.net/thread/435672?tstart=30

0
Comment actions Permalink

Thanks.  It worked.

It seemed to forget about my excluded directories in my project.  I noticed because i have some huge image directories and phpstorm was taking a long time to index them.

I'll check to see if anything else has changed.

m

0
Comment actions Permalink

Thanks.  I did it the simple way.  uninstalling 4.0.1 and then starting again.  

Actually, the first time I did not delete the settings, and when I reinstalled it told me that I needed to install to an empty directory or one that contains PHPStrom 1.0?

Talk about old code!

m

0
Comment actions Permalink

Excluded directories is project specific setting (stored together with other project settings in .idea subfolder). It is not touched by that dialog window or during export/import settings operation.

Don't know what went wrong and why it did not remembered those folders in your case -- have not noticed such problem on my old projects (that I have not touched in v4 yet, including EAP builds)

0
Comment actions Permalink

Thanks, I sorted that now

0

Please sign in to leave a comment.