uft-8 automatically when creating a new file in Jetbrains phpstorms.

I am trying to use Jetbrains phpstorms to code. When I create a new file, I don’t have this line :

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

How can I set this one? I mean when creating a new file, this file automatically contains this line.

(When we use Dreamweaver, it automatically has this line)

Thank you very much.

5 comments
Comment actions Permalink

Hi Hung,

Settings | File Templates

Find the correct template (Html, Xhtml etc) and edit it to match your requirements. Alternatively create new custom template (will be listed as separate entry when doing "File | New...")

0
Comment actions Permalink

Thank you very much.
But I haven't created this line automatically as you told me. I copied this line <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> and paste it in the File templates and "apply". But when creating a new file, I don't see this line.
Thanks.

0
Comment actions Permalink

You have to be doing something wrong or missing some step.

Please provide a screenshot with your template and show how you create new file (describe step by step... maybe illustrate with screenshots). Quite likely wrong/different template is used when you creating new file.

0
Comment actions Permalink

Yes.
What I have done is here.
File->Settings->File Templates.
I paste the line <meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> into the window like this:
http://enan.edu.vn/download/drop.png
But after doing this. I create new file as this:
http://dl.dropbox.com/u/2752840/screens/snap1380-1335104429.png
and the file doesn't have the line I want.
Thanks.

0
Comment actions Permalink

Oh, thank you very much. I have done it sucessfully. Thank you.

0

Please sign in to leave a comment.