PHP code colloring and file-templates gone (plugin fail)

Hi all!

first of all i would like to apologize for my bad English (I'm from Belgium) and I would like to say that I'm still just a student (learned html 6 moths ago, and now learning the basics of PHP (smarty) for about 1 moth)
     you have to start somewhere! ;-)

Specs:
Mac OSX 10.7.3
PhpStorm 3.0.3

In the lessons now, we are using smarty to dynamically make websites.

as php-storm doesn't come standart with smarty-codehinting. You have to include it as an external library. This has always worked.

today I discovered that there is a long list of plugins for phpstorm. also one called PHP and it says that it will give you support for smarty (& php, ect..)
     http://plugins.intellij.net/plugin/?webide&id=6610

so i downloaded and installed.
     the plugin comes in 2 files: php.jar (which installed without any problems) & resources_en.jar (gave me an error when trying to install it: "Fail to load plugin descriptor from file resources_en.jar")

it asked me to restart PhpStorm. when I did that I saw all my PHP-files where listed as normal files (no special icon in the file-tree and no code-hinting/coloring).

trying to remove the plugin didn't gave me back the normal PHP-handling.

was i wrong about the plugin (not ment for what i think it is made?)
And how do I get my PHP-support back?

Allot of thanks to you all!

Wouter

2 comments
Comment actions Permalink

Hi Wouter,

PhpStorm already includes that PHP plugin and has support for Smarty templates (since v1 I believe). The version you have installed is incompatible with PhpStorm v3 (as it is made for upcoming v4). In "Help | About" you can check the branch numbers (PhpStorm v3 is 111.xxx branch while v4 is currently on 117.xxx branch).

How did you installed that plugin? Where did you put those files?

  1. If you placed them in PhpStorm installation folder, then just reinstall PhpStorm (do NOT choose to "remove settings/config files");
  2. If you installed it using "Settings | Plugins" screen, then
    • Close PhpStorm
    • Find folder where PhpStorm keeps it's custom (non bundled) plugins. Sorry, I'm not Mac user so cannot give you exact location, but I think it should be in ~/Library/Application Support/WebIDE10 (or just search for all WebIDE10 folders in your home folder and try to figure it out)
    • Remove that plugin files


After that was done and you still have no "colloring":

  1. go to "Settings | Plugins" and make sure that PHP plugin is there and is enabled
  2. go to "Settings | File Types" and make sure that there is "PHP files" entry and *.php pattern is registered there.


If that does not help for some reason, you can try clean install. You can backup your settings first and then restore them later:

  • directly (best way IMO) -- backup your files in ~/Library/Preferences/WebIDE10
  • from within PhpStorm -- "File | Export Settings ..." and "File | Import Settings ..." accordingly (but do not include plugins in this case).
0
Comment actions Permalink

Thank you verry much for the quick and detailed reply.

the problem was that *.php was not assigned as php but just as a normal file. (the plugin must have changed that).

I have learned again that I maybe have to read first the whole thing and than click click click :-p

cheerz!

Wouter :)

0

Please sign in to leave a comment.