PhpStorm and DocBlox

Hello!

I want to document the use of my scripts DocBlox.
http://www.docblox-project.org/

In addition I have found the following instructions.
http://docs.docblox-project.org/for-users/integrating-with-your-ide.html

I DocBlox installed manually. The 'Path' variable I've changed as follows.
Path: C: \ xampp \ php \ c: \ xampp \ htdocs \ docblox \ bin \;

If I want to use DocBlox I get the following error message.

Who can help?

Yours sincerely,

Stephan



Attachment(s):
fehler.jpg
files.jpg
settings.jpg
5 comments
Comment actions Permalink

Hi Stephan,

  1. When did you set your PATH variable -- before or after launching PhpStorm. If after -- restart PhpStorm as environment variables are copied to the process when it starts and external changes made after that are ignored (better say -- already started process is working with local copy of those variables made when it started).
  2. Double check the PATH variable. If I just copy your path as is I will have an error beacuse I see no path separator between 2 folders: C:\xampp\php\;c:\xampp\htdocs\docblox\bin\; Plus ... try adding folders without slash at the end.
  3. To check #2 -- are you able to execute docblox command in console from any folder .. or do you see the same error as before?
  4. And the last moment -- you can always provide full path to docblox in External Tools: c:\xampp\htdocs\docblox\bin\docblox.bat
0
Comment actions Permalink

Hello!

Thanks for the quick reply.
I changed the settings in 'PhpStorm'.

Unfortunately, I still get an error message.

The name of the file.
c: \ xampp \ htdocs \ test \ docblox.php


I would appreciate any information.

Yours sincerely,

Stephan



Attachment(s):
error.jpg
settings.jpg
0
Comment actions Permalink

What about #1, #2 & #3 ?

Because of the file name that you are using for testing (docblox.php -- the same as docblox itself) it is unclear for me which file is failed to be opened (maybe it worth renaming your test file to something more neutral?). Maybe it is file permission issue?

In any case:

  1. I have installed DocBlox via PEAR (my PEAR is already properly configured (e.g. is in PATH etc)).
  2. Launched PhpStorm and created External Tools entry (exactly as described in manual)
  3. When trying to execute is had the same error as you had in first message
  4. Changed "Program" field from docblox to docblox.bat (it will find it as the folder is already in PATH)

  5. Works fine now


So .. double check your docblox installation, especially PATH.

0
Comment actions Permalink

Hello!

I've done some experiments.

In the cocblox.bat i have changed changed a path.
I have manually changed one line.


@echo off
if "%PHPBIN%" == "" set PHPBIN=php.exe
if not exist "%PHPBIN%" if "%PHP_PEAR_PHP_BIN%" neq "" goto USE_PEAR_PATH
GOTO RUN
:USE_PEAR_PATH
set PHPBIN=%PHP_PEAR_PHP_BIN%
:RUN
"%PHPBIN%" "c:\xampp\htdocs\docblox\bin\docblox.php" %*

I becam a error message.
No xsl.dll found.

I have insert the Line
extension=php_xsl.dll
in the 'php.ini'.

Now i becam the error message:

-----------------------
C:\xampp\htdocs\docblox\bin\docblox.bat -d C:\xampp\htdocs\test -t C:\xampp\htdocs\test/docs/api
DocBlox version 0.18.1

Starting transformation of files (this could take a while depending upon the size of your project)
2012-03-30T13:36:34+02:00 ERR (3): Unable to find the `dot` command of the GraphViz package. Is GraphViz correctly installed and present in your path?
Finished transformation in 1.95 seconds

Process finished with exit code 0
-----------------------

I give up and find another program.

Yours sincerely,

Stephan

0
Comment actions Permalink

1) I'm afraid all these error messages have nothing to do with PhpStorm -- it's not properly installed/configured DocBlox itself (missing required supplemental libraries etc).
You just need install additional libraries

2) 2012-03-30T13:36:34+02:00 ERR (3): Unable to find the `dot` command of the GraphViz package. Is GraphViz correctly installed and present in your path?
It is just another dependency -- to build some graphs (components hierarchy etc).

3) Process finished with exit code 0
This clearly indicates that documentation was successfully generated, although some graphs (see "Charts" section of the navigation in generated documentation) will be missing.

4) I give up and find another program.
The choice is yours

0

Please sign in to leave a comment.