Adding remote folder to remote project

Hi all,

I have created a remote project which is on a network drive (windows machine connecting to a linux samba server). I have added a folder on the linux server and would like this folder to show up in my project. But even after clicking Download from Download from <configuration>, on the project's root, this folder doesn't show up in the project. The folder is not excluded (meaning: it does not appear in the list of excluded folders found in File -> Settings -> Directories and not in the list of excluded folders found in File -> Settings -> Deployment -> Excluded Paths).
How do I make this folder show up in my project?

5 comments
Comment actions Permalink

Hi!  Is that folder mapped? Check Remote Host view for that server, folder's background should be green. Set Tools | Deployment | Options | Operations Logging to Detailed, try to download folder from Remote Host view and have a look at log in File Transfer toolwindow. Maybe that folder is mapped to a place outside your project.

0
Comment actions Permalink

I'm not sure.. None of these folders are green.. Here is a screenshot, the folder public_html/pub_lesplan is the folder I'm talking about:
http://geensite.nl/tmp/ss_folder.png
The logging is set to Details, and I just clicked Download from here on the projects root (Ontwikkel remote (Z:\)), which is the only place I can click Download from here.

Hope you can help me out. If you need anything else just let me know.

0
Comment actions Permalink

Hi Henk,

  1. Settings | Deployment
  2. Find your deployment entry for this project ("Ontwikkel remote" I assume)
  3. Make sure that everything is set correctly on Mappings tab (it looks like it is not configured properly). If unsure -- please post a screenshot of it.
0
Comment actions Permalink

Hi Andriy,

This is what I have on the Mappings tab. Note that debugging works perfectly, so I guess this is the way it should be?
http://geensite.nl/tmp/ss_deployment.png

0
Comment actions Permalink

Use back slash "\" (or forward slash "/" -- both work fine here) instead of dot "." for "Deployment path on server" field.

0

Please sign in to leave a comment.