Remove tab indent?

When I hit the tab, then my code gets indented 4 characters. When I hit the return button on the keybord the cursor moves just one position? I can't find the option in the settings that controlls the behavor of this?
Any help is appreciated!

3 comments
Comment actions Permalink

Hi Daniel,

In what context do you see such behaviour (php, html, css etc)?

For settings -- please check these:

  • Settings | Editor | Smart Keys | Enter | Smart indent
  • Settings | Code Style | <choose your language/technology> (inluding "General")
0
Comment actions Permalink

Hey Andriy,
So here is the file that i'm working on:

<?php

require_once(JPATH_COMPONENT_SITE . DS . 'views' . DS . 'json.php');
class hotspotsViewKmls extends HotspotsJson
{
    
    public function display($tpl = null)
    {

        $this->kmls  = $this->get('Kmls');
        parent::display();
        
    
    }
}


before the require_once -> the indent and back works as I expect it
before public function display - it is also fine
before $this->kmls it is also fine
on the line of this kmls -> when I click the tab and I try to return, then I have to hit return 4 times to get back.
After parent it behaves as I expect it.

I checked the settings that you refer to -> smart indent is turned on in General and for PHP as well.

Daniel

P.S. I use EAP 116.101

0
Comment actions Permalink

TBH I'm confused.

when I click the tab and I try to return, then I have to hit return 4 times to get back.

What do you mean by "hit return" -- do you mean pressing "left arrow" button?

If you enable "View | Active Editor | Show Whitespaces", will you see 4 dots (spaces) or "->" this kind of symbol (tab)?

---

Can you please attach this example file here as well as your Code Style settings (via "File | Export Settings" .. or directly -- from ~/.WebIde40/config/codestyles/<YOUR_STYLE_NAME>.xml)

Maybe that "Smart Tab" is the reason for that (uses xx spaces instead of 1 tab).

0

Please sign in to leave a comment.