Stop an indent on paste

I've disabled indenting on title, but when I paste in the following code under a title tag,

<link rel="stylesheet" href="http://code.jquery.com/mobile/latest/jquery.mobile.min.css" />
<script src="http://code.jquery.com/jquery-1.7.1.min.js"></script>
<script src="http://code.jquery.com/mobile/latest/jquery.mobile.min.js"></script>


WebStorm indents it every time.

How can I disable this?

Also - can I say the most annoying thing I've found in WebStorm so far is the fact that I can't tell it to just NOT indent, period. I have to keep adding tags to the list of things not to indent.

2 comments
Comment actions Permalink

Ugh. Brain fart. I had added "title" to my list of things not to indent under, but of course, my tags were under HEAD.

-sigh-

Still though - can we please have an option to not indent, ever?

I'm one of those crazy people who hate my editor doing anything - adding quotes, indenting, etc.

0
Comment actions Permalink

Hi Raymond,

Have also look at:

  • Settings | Editor | Smart Keys --> Reformat on paste
  • Settings | Editor | Smart Keys --> Enter | Smart Indent

can we please have an option to not indent, ever

With single click -- no (highly doubt). AFAIK you have to configure your own Code style for that (just finish what you have been doing already).

0

Please sign in to leave a comment.