Need Help with PHPUnit

I installed pear, phpunit all that good stuff

now when i try to generate a test i get the following message

PHP Warning:  require_once(PHPUnit/Runner/Version.php): failed to open stream: No such file or directory in /private/var/folders/gm/fbxyj6n93td_z4vtgsfgrblr0000gp/T/ide-phpunit.php on line 102
PHP Fatal error:  require_once(): Failed opening required 'PHPUnit/Runner/Version.php' (include_path='.:/usr/lib/php/pear') in /private/var/folders/gm/fbxyj6n93td_z4vtgsfgrblr0000gp/T/ide-phpunit.php on line 102



Any ideas?

Also i dont get want the dialong means by configuration file and bootstrap file
1 comment
Comment actions Permalink

Hi Shahin,

You have to verify the value of include_path config variable in your php.ini.

PhpStorm executes some custom phpunit helper file, which is an ordinary .php file and during execution PHP interpreter is unable to find the PHPUnit files (in particular 'PHPUnit/Runner/Version.php). Either include proper path in your include_path (in php.ini -- preferred way) or provide such path in your bootstrap file (e.g. via set_include_path() or some custom class loader function).

Also i dont get want the dialong means by configuration file and bootstrap file

I have no idea what you are trying to say here.

0

Please sign in to leave a comment.