Error occurred during generating of skeleton test case class

What should I do to deal with this error:

Generate PHPUnit Test: Error occurred during generating of skeleton test case class

?

It worked in the past but that was befre phpstorm v3

9 comments
Comment actions Permalink

Hello Tom,

What is your PHPUnit version? Do you use any phpunit configuration/bootstrap files in your project?

Thank you for feedback!

0
Comment actions Permalink

PhpStorm Version 3.0 Build #PS-111.19

bootstap.php:

<?php
$yiit=dirname(__FILE__).'/../../../yii-1.1.9.r3527/framework/yiit.php';
$config=dirname(__FILE__).'/../config/test.php';
define('YII_DEBUG', true);
define('PHP_UNIT', true);
require_once(dirname(__FILE__).'/../../../shared/globals.php');
require_once($yiit);
require_once(dirname(__FILE__).'/WebTestCase.php');
Yii::createWebApplication($config);


phpunit.xml:

<phpunit bootstrap="bootstrap.php"
colors="false"
convertErrorsToExceptions="true"
convertNoticesToExceptions="true"
convertWarningsToExceptions="true"
stopOnFailure="false">

<selenium>
<browser name="Firefox" browser="*firefox" />
</selenium>

</phpunit>



Both unit testing and functional testing with selenium server are working fine. I just can't generate unit test templates using PhpStorm.

What function key do i gotta press to markup code in this editor?

0
Comment actions Permalink

Tom,

Please try to set path to your configuration file in the action dialog:
configuration_file.png


Thank you for feedback!

0
Comment actions Permalink

All fields in the dialog are set correctly, as you specified.

0
Comment actions Permalink

Tom,

Please provide command line command which PhpStorm generates for your class.

Thank you for feedback!

0
Comment actions Permalink

I don't know where to find that information. It is not in PhpStorm's Event Log. That only has the error message.

0
Comment actions Permalink

Tom,

Please look at the screenshot
command_line_command.png

Thank you for feedback!

0
Comment actions Permalink

i was unable to display a '4: Run' panel.

i think because in setting:project:php the interpreter had was set to '<no interpreter>'. i selected 'php (5.3.8)' from the menu and generating the test case works now.

probably the upgarde from ps 2 to 3 was responsible. it disrupted a great many other settings.

0
Comment actions Permalink

Tom,

i think because in setting:project:php the interpreter had was set to '<no interpreter>'.

We will provide more clear error message.

probably the upgarde from ps 2 to 3 was responsible. it disrupted a great many other settings.

Sometimes it is hard to provide full backward compatibility.

Thank you for feedback!

0

Please sign in to leave a comment.