file acl rights get lost when edit over a shared directory

Hi,

any idea is very welcome I have no idea where I should look at. Here my configurration:

MacBookPro
VMware fusion 4.0
virtual machine with ubuntu (11.10-server amd64)
a local directory is mapped as htdocs in the virtual machine

I created a project
* Create New Project from existing files
** Source files are in a local directory, no webserver is yet configured

I configured the webserver and debugger and all works good togehter, but when I change a file (no need to save, it is enough when I make a change in PHPStrom) my file ACL right change to:


-????????? ? ?   ?          ?                ? rd_addphp.php   <-- I changed this file
-rw-rw-rw- 1 501 dialout 1189 2011-12-26 09:36 rd_addphp.xml


the funny thing is when I open the file and close it without a change then it is like it was before I made the change in PHPStrom


-rw-r--r-- 1 501 dialout 2978 2011-12-27 12:00 rd_addphp.php
-rw-rw-rw- 1 501 dialout 1189 2011-12-26 09:36 rd_addphp.xml


My problem is that the webserver can't access the files with the stange acl. The reason for this configuration is that I can easly map my development version within a webserver and test it.

As I said any hint is very welcome.


Cheers,
Robert
9 comments

Hi Robert,

Let me please clarify something:

1. original permissions: -rw-r--r--
2. open file in PhpStorm, make some changes, close file, permissons now are: -rw-rw-rw-
3. open file in PhpStorm, make no changes, close file, permissons now are: -rw-r--r--

Is this correct? Or did I miss the step "2,5. reset permissions back to -rw-r--r--"?

Kirill

0

Hi Kirill,

thanks for looking into it.

Here it is what happens:

1. original permissions: -rw-r--r--



2. open file in PhpStorm, make a change, permissons now are:  

-????????? ? ?   ?          ?                ?


3. open file in with vi over the terminal, don't make a change, close the file ":q"
-> back to -rw-r--r--

I can also open the file with textmade or other editors and make a change then the file permisions don't get lost.


Cheers,
Robert

0

Is file permissons actually look like

-????????? ? ?   ?          ?                ?.

Can you attach a screenshot?

0

Sure I can do that, made a couple of it :-)

http://dl.dropbox.com/u/959364/phpstorm.mov

You can see a terminal window connected to my virtual machine and you see the acl rights, then I do a simple change in PHPStorm and then you can see the file rights after it.

Cheers,
Robert

0

Hi Robert,

Thanks for the video!

At the moment I'm not sure about the reason - looks like file record is screwed up somehow, maybe VMware drive mapping is the cause. For now I would suggest the following: download PhpStorm 3.0.1 EAP build, go to PhpStorm -> Preferences -> General and uncheck 'Use Safe write' checkbox. Please get back to me to know if this helps.

Thanks,
Kirill

By the way, any drive mapping is not an officially supported use case, as we always recommend users to work with locally-stored project files since IDE very much relies on instant access to them to provide the best performance and coding assistance.

Message was edited by: Kirill Safonov

0

Hi Kirill,

thanks again for taking a look. I did what you have proposed but it didn't change the acl problem.

I played around with the options and it seems that it is the save action or a part of that action that messed up the acl. I checked changing a file over the shared directory with all other editors I have installed and I found the same problem with Coda, Espresso and textedit. I will open a ticket for VMWare fusion, looks finally like a problem that should be sovled in VMware. I'll keep you posted!

You said that this is "not an officially supported use case", what is your suggestion for a setup with a virtual machine running localy?

Cheers,
Robert

0

Hi Robert,

Thanks for checking the other editors.

For this kind of setup we recommend to copy project files to local hard disk over FTP/SFTP/mounted folder, and then upload the changes you make back to the server (manually or automatically). Check out main menu: File -> New Project from Existing Files wizard. After you created the project you can activate automatic upload via Tools -> Deployment -> Automatic Upload option.

Example: http://tv.jetbrains.net/videocontent/working-with-web-projects-via-ftp

Cheers,
Kirill

0

Hi Kirill,


I got an answer from the vmware support, this is a known bug.

We are aware of this issue and a problem report has been raised with our Engineering and development group.There doesn't appear to be any temporary workarounds, this issue has been marked to be fixed in the future release/update of Fusion.


Thanks for your time and help.

Cheers,
Robert

0

Please sign in to leave a comment.