Bug in remote PHPUnit 3.6 on PhpStorm 3.0?

I tried to setup new PhpStorm (111.19) to work with remote PHPUnit 3.6 and gets error: "Failed to retrieve test results from the server at 'http://devel-server/Tests/_intellij_phpunit_launcher.php'.".
On direct run from browser 'http://devel-server/Tests/_intellij_phpunit_launcher.php' retruns:
E_WARNING: require_once(PHPUnit/Runner/IncludePathTestCollector.php): failed to open stream: No such file or directory
#0 /var/www/htm/Tests/_intellij_phpunit_launcher.php(247): require_once()
E_COMPILE_ERROR: require_once(): Failed opening required 'PHPUnit/Runner/IncludePathTestCollector.php' (include_path='.:/usr/lib64/php')
#0 /var/www/htm/Tests/_intellij_phpunit_launcher.php(247)


And realy it is "require_once 'PHPUnit/Runner/IncludePathTestCollector.php';" on line 247 without any conditions.
But there are no PHPUnit/Runner/IncludePathTestCollector.php in PHPUnit 3.6.

So is it a compatibility bug, or I should install some additional dependency?

Thanks.

2 comments
Comment actions Permalink

Hi Artem,

It's a known issue and fixed already -- http://youtrack.jetbrains.net/issue/WI-8710?projectKey=WI

Fix will be available in v3.0.1

0
Comment actions Permalink

It also may be related to issue http://youtrack.jetbrains.net/issue/WI-8355 which has a workaround that helped remote PHPUnit debugging work for me (though it was PHPUnit 3.5).

0

Please sign in to leave a comment.