Breakpoints Ignored in PHP Debugging (except if on first line of file)

When I initiate debugging from within PHP Storm, it ignores all breakpoints that are not on the first line of a file. Effectively, I can only "debug" by setting a breakpoint at the beginning of a file, or by checking off the option that automatically breaks at the first line in the debugging settings. This means that I have to press "Step Into" or "Step Over" many times to get to where I want in the code.

I can't recall when this started happening, or what triggered it, but I have not had this issue before with PHP Storm and this code base.

Here is a screen shot of my server configuration:
Screen Shot 2011-10-26 at 11.46.15 AM.png
Here is a screen shot of my debug settings:
Screen Shot 2011-10-26 at 11.47.33 AM.png

Here is a screenshot of my debug configuration:
Screen Shot 2011-10-26 at 11.48.40 AM.png
I have attached the xdebug log, as per the directions here: http://xdebug.org/docs/remote#remote_log

In case the screenshots are too difficult to see in the post, I have also attached them to the post.



Attachment(s):
Screenshots.zip
xdbglog.log.zip
3 comments
Comment actions Permalink

Alexander,

Thank you for screenshots and logs. Looks like this problem is related to file path case, though Mac is case-insensitive.

Please try to fix it in the following ways:

  • Add the following path mapping to your server configuration: /Applications/MAMP/htdocs/BFC <-> /Applications/MAMP/htdocs/bfc
  • Set start url to ''http://localhost:8888/BFC/index.php


Try both solutions separately and then let me know about results.

Thank you for feedback!

0
Comment actions Permalink

Hi Nikolay,

The first solution (adding a path mapping) did not work. I might have done it incorrectly: local path = "/Applications/MAMP/htdocs/BFC"; web path on server = "bfc". I did it this way because the project url looked reasonable with these settings: http://localhost:8888/bfc . If I typed in the full path for 'web path on server', the project url looked very strange.

The second solution, however, worked perfectly. Setting the start URL to http://localhost:8888/BFC/index.php with an uppercase "BFC" instead of a lowercase "bfc" (which is what I had before) corrected the problem.

Thank you for your help.

0
Comment actions Permalink

Hello Alexander,

Do you still have any issues with debugging?

The first solution (adding a path mapping) did not work. I might have done it incorrectly: local path = "/Applications/MAMP/htdocs/BFC"; web path on server = "bfc". I did it this way because the project url looked reasonable with these settings: http://localhost:8888/bfc . If I typed in the full path for 'web path on server', the project url looked very strange.

Yes, your path mappings were wrong. The second column is a physical path. So the following is correct path mapping:

/Applications/MAMP/htdocs/BFC <-> /Applications/MAMP/htdocs/bfc

The second solution, however, worked perfectly. Setting the start URL to http://localhost:8888/BFC/index.php with an uppercase "BFC" instead of a lowercase "bfc" (which is what I had before) corrected the problem.

It might be Apache or Xdebug internal problem. I will investigate that - http://youtrack.jetbrains.net/issue/WI-8792

Thank you for feedback!

0

Please sign in to leave a comment.