Running out of memory - how to increase? (windows 7)

I've got 16GB of ram on my machine, and PHPStorm is running out of memory!

It's giving me some errors asking to increase or ignore. I've tried increasing before and made the IDE unbootable.

How do I increase the amount of memory available to the IDE?

4 comments
Comment actions Permalink

You can try change settings in file bin\PhpStorm.exe.vmoptions

0
Comment actions Permalink

Basically this means that you consistently hit some performance problem - and you should report it properly so we can address it, see
http://devnet.jetbrains.net/docs/DOC-192

Anyway, maximum amount that you should try to set in OOM dialog is about 1G.

0
Comment actions Permalink

I know this isn't new, but I don't have problems with PhpStorm at all, I just tend to have a few projects, a lot of files, and mostly big files open. When my memory maxes out, I wish there was a way to increase my memory. I followed the directions above, but it seems I can only max the settings out up to this point before it refuses to start:

-Xms32m
-Xmx720m
-XX:MaxPermSize=900m



Is there a reason I can't use more RAM even though I've got 6GB?
0
Comment actions Permalink

You've got it totally wrong. You don't need to touch MaxPermSize ever.
Max total memory is about 1.2G.
Revert Perm back and you'll be able to add it to Xmx.
And adding more memory won't really help to speed things up.

0

Please sign in to leave a comment.