Weird indentation in .txt files when pasting (EAP 110.437)

Indentation is working like a treat in php, javascript and css files.
I just have problems in .txt files.

For instance, I have a CHANGELOG.txt that has this format:

18-Nov-2011 : v1.2.3
 # Fixed issue ...
 # Fixed issue ...
 # Fixed issue ...


When I copy/paste one of the # lines, the result of the pasted lines is:

18-Nov-2011 : v1.2.3
                     # Fixed issue ...
                                       # Fixed issue ...
                                                         # Fixed issue ...


I don't know how to make it just indent the 1 space...
Changing the "Code Style >> General >> Default Indent Options" has no effect on this.

6 comments

Hi Peter,

Please try changing the setting for "File | Settings | Editor | Smart Keys | Reformat on Paste"

0

I have that set to "Reformat Block", which is what I want and is working fine on other filetypes, like php (like explained above).
But this isn't working fine in txt files...

0

PS: Just updated to 110.518. Still same problem...

0

Please submit a report to Issue Tracker ( http://youtrack.jetbrains.net/issues/WI ) providing as much details as possible.

0

Ok, done :)
http://youtrack.jetbrains.net/issue/WI-8591

PS: I don't get email notifications of answers on my threads in this forum :S
I am 'following' the thread ("Stop email notifications" option is available)

0

PS: I don't get email notifications of answers on my threads in this forum :S
I am 'following' the thread ("Stop email notifications" option is available)

I've no such problem (happy me :) ) -- always got notification emails delivered. Check your Spam folder maybe (to start with) .. and profile settings as well (I have all 4 set to "yes"), correct email address.

0

Please sign in to leave a comment.