on OSX 10.5.8 : no compatible version of Java 1.6* is available

Why am I getting this?
I tried installing 1.6 manually but I get "there is a newer version already installed"

0
4 comments

When are you getting this?... What steps do you perform?...

0

After some digging it seems taht since I have a 32 bit OS I can only get the 1.5 version of Java,
When I try ro run PHPstorm (click the icon in the applications folder) I get the error messege I posted.

0

As it pointed on Download page's System Requirements section:

  • Mac OS X 10.5 or higher, including 10.7 (Lion)
  • JDK 6

Unfortunately it looks like you can't run PhpStorm 2.0+

0

Hi Alexey,

I have exactly the same problem, the same message.
I was running WebStorm Ok for a while, but then it stopped working with the previous error message prompted. The only thing I was doing before the error was updating iTunes and changing the WebStorm app icon. I don't know if that makes any sense. I re-installed the app but the problem persists.
My setup is:

  • Mac OS X 10.6.8
  • JDK 6


Thank you in advance,

Daniel

0

Please sign in to leave a comment.