PHPStorm - Create file without .php extension bug

THIS IS REALLY A MEAN BUG

when i forgot to create a file > file > new with a valid .php extension, PS creates a .txt file by default. Renaming the file will not change its type to php in fact it is not even parsed as php file. its stays a .txt file FOREVER. i can only delete it but if i create a new .php file under SAME NAME its stays a .txt file. Reindexing does not change, Restart neither nothing. i can not use the filename as php filename anymore!

this sucks

2 comments

That's not a bug - it asks you to what filetype assign the unknown name.

goto Settings | File types | text and remove names

1

ah ok i see. but if you dont know about the association dialog under file types it looks like a bug :) ... never mind i love Storm!

0

Please sign in to leave a comment.