Deploying to FTP

Hello,

I can't seem to figure out how to deploy an existing project to ftp.

In the past I've been able to start a project directly from FTP files on my external server, but then I had difficulties debugging on internal MAMP.
So I've started a local project, but now I can't upload the project using PhpStorm because the menu items under the Tools >> Deployment are grayed out.

I'm still a newbie at this software - can anyone help with some advice or some links?

Thanks!

8 comments
Comment actions Permalink

Hi Leo,

Have a look at File | Settings | Deployment. Click on "+" button and create new server config choosing FTP (or SFTP) as "Access type" (should be pre-selected by default anyway). After that you will be able to use "Deployment" menu.

0
Comment actions Permalink

I guess what confused me is that I already had a server mapping to the same one from the other project and I thought it would just work with any project.

I did however create a new one thats identical and it worked.

One more question - is there a way to exclude certain files from uploading? Like a configuration file for example.

0
Comment actions Permalink

Hello Leo,

You can exclude files and folders by mask: check 'Exclude items by name' settings at File | Settings | Deployment | Options dialog.

Regards,
Kirill

PS Thanks Andriy!

0
Comment actions Permalink

Very cool. Thanks so much!

0
Comment actions Permalink

Hi, I've set up my FTP details in Deployment Configuration, and I'm able to connect OK and browse remote host. But the Deployment menu in the context menu in all my projects - as well as the upload/download optins under Deployment - are greyed out. What gives?

Thanks

0
Comment actions Permalink

Hi,

Have you set up deployment mappings that define the association between local and server folders? (see File | Settings | Deployment | (your server) | Mappings tab). Menu items should be enabled for local and remote files or folders located under mapped roots.

Cheers,
Kirill

0
Comment actions Permalink

Ah thanks Kirill, that's what it was. I needed to put a / in the field for the server deployment path and web path on local server. I didn't notice PHPStorm's warning about that on the mappings tab.

You guys are great! I'm recommending PHPStorm to my colleagues at work - much better than crappy Eclipse or NetBeans.

0
Comment actions Permalink

Thanks! Indeed, web path is not required for files deployment, it's used to compute URL of selected file on server for 'Open on <server>' action.

0

Please sign in to leave a comment.