PHPUnit + OSX + brew = incomplete autocomplete?

I'm running EAP 110.122 on OSX 10.7, with php and phpunit in a brew install cellar.  My co-worker has this issue with 2.1.5, so it's likely not a version-specific problem.

My issue is that when writing phpunit tests, I cannot autocomplete $this->assert which should have dozens of choices.  Instead, I see two esoteric examples of test assertions.  When I installed phpunit via brew-installed pear, I have to manually link the executable into my path.  I'm guessing there's a library I haven't linked yet, but I thought I'd throw a question out there in the hopes that there is someone more knowledgable than myself.

Any tips on how to get autocomplete running?

1 comment
Comment actions Permalink

Answering my own question:

Open the settings dialog.

Under PHP, add the full path to your lib path in the Cellar, e.g. /usr/local/Cellar/php/5.3.6/lib/php

Hit the refresh button if it's not reading it already.  Ok, and wait for Storm to reindex.  Problem solved.

0

Please sign in to leave a comment.