Using PHPUnit From A VMWare Server

So I am running a Mac and have a CentOS 5.4 VM running under VMWare Fusion.  I have PHPUnit installed, configured,a nd running properly on the VM.  I tried to setup a run/debug configuration however when I run it I get the following from PHPStorm:

Testing started at 3:35 PM ...
Executing tests
Failed to retrieve test results from the server at ''.

This is the first time I am trying to setup any IDE to use a remote server to phpunit testing so I am not sure what I am doing wrong.  Any help would be great.

Screen Shot 2011-09-08 at 3.43.51 PM.png
Screen Shot 2011-09-08 at 3.44.07 PM.png
Screen Shot 2011-09-08 at 3.44.16 PM.png
Screen Shot 2011-09-08 at 3.44.35 PM.png
Screen Shot 2011-09-08 at 3.44.47 PM.png

Comment actions Permalink

Any help with this please, it would be sucka  useful feature for me to be able to use.  Do anyone currently have phpunit working where the server is on a local VM with the code as a shared folder between the host and guest vm?

Update: I think I actually know the issue, will report back once I try a few things

Update: My stupidity, I forgot about the rewrite rules I have on this site so I just needed to update the VHOST configuration on my VM (also had to switch my Development config to SFTP SFTPing to fiel to the server will just overwrite the file with the same file since that folder is mapped to the files I am editing on my computer).

Comment actions Permalink

Hello Ryan,

Do you still have the issue?

Thank you for feedback!


Please sign in to leave a comment.