550 Overwrite permission denied

PS# 107-592

i just started getting
"550 Overwrite permission denied" errors in the file transfer dialog.

It was working yesterday, other FTP programs work fine, It works fine if i delete the file from the server, then re-upload.

but it slows things down a Lot.  Not cool when your on live chat and fixup stuff with the client.

any known workarounds please?  I tried restarting PhpStorm.

here is the full line:
[15/09/11 11:49] Failed to transfer file '/home/me/lots/of/directories/the.file.class.php': cant open output connection for file "ftp://ftp.the-site.com/folder/the.file.class.php". Reason: "550 folder/the.file.class.php: Overwrite permission denied".

5 comments
Comment actions Permalink

Hi Michael,

Do you know if anyone changed server settings?

And as usual, I would like to ask you for FTP logs.

Thanks,
Kirill

0
Comment actions Permalink

My best guess for server settings is me having several FTP clients open at the same time,

PhpStorm and a couple of Konqueror instances all pointing at the server.  Im guessing some auto blacklist thingie kicked in and kicked me off.  Ive had that happen to me before.

but usually when i get kicked i get totally kicked, cant login.

This situation is I can login, I can see the full directory structure as usual, I can upload if there is no file that exists, I can delete, but I just cant upload over the top of a file.

Where should i attach it too?  Id rather not make my logs public if possible.

as a side suggestion, each time i upgrade PhpStorm, i have to re-do this add the debug into log.xml  Could the setting be moved to /.Webide10/ folder so it persists over upgrades.  I just looked and although i setup the debug to go to the logs, i must have upgraded since then, so im going to need to recreate it to get a useful log for you.

0
Comment actions Permalink

Hi Michael,

Where should i attach it too?


Please attach logs to a new bugreport, or send them directly to me: kirill (dot) safonov (at) jetbrains (dot) com.

each time i upgrade PhpStorm, i have to re-do this add the debug into log.xml


Additionally, I would suggest to provide UI for tweaking log settings: see http://youtrack.jetbrains.net/issue/IDEA-74428.

Regards,
Kirill

0
Comment actions Permalink

The problem at least for me seams to have gone away.

Im not sure if it was the update to 2.1.5 or the time lapse that reset something on the server but I can once again upload to the server.

0
Comment actions Permalink

Michael, 2.1.5 update does not contain any related changes. Anyway, it's good news, let's see how it goes.

Kirill

0

Please sign in to leave a comment.