SVN behavior in PhpStorm 2.1.2

Hi,

the behavior of the SVN integration seems to have changed in version 2.1.2. In older PhpStorm versions all new files got added to the repository by default and you could mark them to be ignored by version control.
In the current version you've to explicitly add the files you want to add to svn. That's a nice feature, because it reduces the risk to add files, that shouldn't be under version control. But this changes brought also a bug with the ignore feature.
If you add a folder recursivly with all files in it, you can't ignore one of the containing files anymore. The ignore option is just disabled.
That is really annoying, because that way you can just recursivly add folders that only contain files that should be under version control. In other cases you've to add each file seperatly.

Is there any workaround for that problem?
And are there any plans to fix that in the next version?

1 comment
Comment actions Permalink

Hi,

my mistake... the SVN GUIs made me lazy so i didn't recognize that the behavior of PhpStorm 2.1.2 SVN component is exactly like it's at the command line. Of course i've first to revert the files i added and then ignore them.

Anyway it's annoying that PhpStorm doesn't do that for me automatically, like other frontends. So if there is a not committed but added file, just don't disable the "ignore" button and do the action "revert->ignore" instead of just ignore, when it's clicked.

0

Please sign in to leave a comment.