Deployment blocked by Windows Firewall

Hi,

I got this error message for a few days now: "Automatic upload failed: could not list the contents of folder", when I try to upload my project via FTP (Deployment).
I didn't change anything at all around the windows firefall, but when I disable it, everything is fine. It was also fine all the months I'm using PHP Storm.

What can I do to use the ftp upload and the windows firewall at the same time?
PHP Storm itself is NOT blocked by the firewall (it's allowed in the firewall settings and I didn't change them).

Please excuse my English, I try my best.

Thanks!

2 comments
Comment actions Permalink

Hi Andy,

Please try 'Passive mode' option at File | Settings | Deployment | (your server) | Advanced Settings dialog.

Regards,
Kirill

0
Comment actions Permalink

Thanks for your response. I tried passive mode and compatibility mode (both activated,  bothdeactivated and only one of them activated).
I haven't changed anything in my deployment settings and / or firewall settings the last weeks.

I tried a fresh installation with a completly new configuration file and now it's working.
But as I said, I did not change any settings and I tried all the settings above to solve the error.

Excuse the circumstances and thanks for your response.

0

Please sign in to leave a comment.