ssh+svn and config file

Hello,

I setup a ssh config file(~/.ssh/config) on my Mac and it works fine for avery app except phpStorm :(
How can I tell phpStorm to use the config file? It allways ask me for my credentials :(

Thanks for you help,
Urkman

1 comment
Comment actions Permalink

Alas, PhpStorm doesn't use the SSH config file. There's an issue filed for it at:

http://youtrack.jetbrains.net/issue/IDEA-58722

It's not received any attention in the seven months since it was filed, though, so I'd encourage you to let JetBrains know that this issue is important to you.

In the mean time, depending on what settings you're changing in the config file, you may be able to work around the problem to some extent. In my case, I added a new entry to /etc/hosts corresponding to the Host value value from the SSH config file (assuming it's a custom name not matching the real hostname specified by the HostName value), and then in the PhpStorm auth window, I entered my username and pointed it to my private key file. If you have a special port number you need to use, you can also indicate that in the dialog, I believe. What I don't think you can do is tweak the non-basic settings, things like the connection compression.

0

Please sign in to leave a comment.