Debuging on local IIS

Hi Guys,

I have just started using Webstorm 2.0 and is trying to setup my development environment. I am running as an ASP.NET application on my local IIS and has a small problem wen running/debuging. When I try to run or debug from Webstorm the are opened in firefox but get referenced by file rather then from localhost ("file:///C:/Repositories/Work..."). Is there a way for me to configure toe debugger to start from localhost instead?

8 comments
Comment actions Permalink

Hello Tomas,

You should use "JavaScript Debug ->  Remote" run configuration in this case and specify correspondent web mapping.

Thank you for feedback!

0
Comment actions Permalink

Hi,

thanks for your reply. I actually got this to work but after reinstalling windows on my computer yesterday and trying to set up WebStorm its not working as it used to. If I follow your suggestions I can add a remote configuration and if I press the debug button in the toolbar it starts on localhost. so far so good...

but, if I right click on the file in the "project window" and choose "debug" the configuration get changed by WS and switch to local prior to remote. If press "Open in Browser" (on right click menu) it always opens the file by reference ("file://"). These things used to work before I reinstalled but I have no idea what I did to get it to work the first time. Any ideas?

Regards
Tomas

0
Comment actions Permalink

You need to configure mapping from local files to browser urls. Open Settings | Deployment, add a new server and configure mapping on 'Mappings' tab.

0
Comment actions Permalink

Hi Nikolay,

I tried this but without any success. I added a new deployment setting with access type "Local". this one is pointing to "http://localhost" and under mappings the local path is set to "C:\Projects\Work". Its still opening the files by "file reference"...

0
Comment actions Permalink

Is that server marked as default on 'Mappings' tab?

0
Comment actions Permalink

Yes it is.

I also installed the latest version (103.243) and tried but same error. Any more ideas?

/Tomas

0
Comment actions Permalink

I just got it to work!

what I did was to add a path to the "Web path on server 'localhost'" in the mappings tab. WebStorm didnt like when this field was left blank and since I had the "C:\Project\work" directory mapped to the root of my local IIS server it was left blank. I changed my local path "C:\Project\work\somepath" and then added "somepath" as web path.

Regards
Tomas

0
Comment actions Permalink

Tomas,

Thanks for sharing!

0

Please sign in to leave a comment.