How to stop PhpStorm from re-indexing every few minutes

I've got PhpStorm 2.0 setup on my Ubuntu 10.04. I've setup 2 different projects in the past, and in both of these projects it only indexes upon opening the project. In this project it re-indexes every few minutes. All 3 of these projects have been hooked up to Subversion. I have a theory that it is re-indexing after Subversion updates, but I'm not sure.

How do I disable Subversion auto-updating (if that is the issue), or how do I disable re-indexing?


Thanks ahead of time!

Rob

3 comments
Comment actions Permalink

Well not sure what's happening on your side but you may try to disable subversion integration for one session at Settings|Version Control to quickl check whether its related to reindexing...

0
Comment actions Permalink

Go to File -> Invalidate Caches and Restart.  Fixed my issue - https://www.prodjex.com/2018/03/phpstorm-stuck-re-indexing/

0

Please sign in to leave a comment.