debugger on mac starts firefox on windows vm

I'm running WebStorm on my mac.  I have chrome, FF4 on my mac, as well as vmware fusion.

When I try to debug javascript, the debugger tries to load it from firefox on my windows virtual machine instead of the Mac installed version.

6 comments
Comment actions Permalink

What path is specified in Settings | Web Browsers | Firefox?

0
Comment actions Permalink

I have "use system default browser" checked.  and it simply says "firefox", the firefox settings point to :/Users/<user>/Library/Application Support/Firefox/profiles.ini

0
Comment actions Permalink

When you start JavaScript debugger 'use system default browser' option isn't taken into account. WebStorm uses command in 'Firefox' section to start Firefox.

0
Comment actions Permalink

I complained about this a couple of months ago. On Mac, if PHPStorm can find Firefox it will launch it to debug js. The only way around this is to remove Firefox.

0
Comment actions Permalink

I was able to work around it by changing the location to /Applications/Firefox.app instead of 'Firefox'.

0
Comment actions Permalink

Humm.. didn't think of trying that. Thanks.

0

Please sign in to leave a comment.