PHPStorm Won't Start!!!!!

Answered

It was working fine, restarted my computer, and now...it flashes and disappears....what the heck???

16 comments
Comment actions Permalink

Tried a different version, but no go.

0
Comment actions Permalink

Re-installed Java. No go. HELP!!!

0
Comment actions Permalink

Works when I log into this machine as a different user.

0
Comment actions Permalink

Hi Keith,

I think it is your profile (I mean -- PhpStorm config).

1) Have you recently installed or upgraded any plugins? If so -- remove them. Even if you have not -- try removing them (back up first).

2) Removing .WebIde10\system folder (where all indexes/caches/logs etc are stored) may also help.

3) I would recommend back up PhpStorm config (C:\Users\USERNAME\.WebIde10\config), then delete it completely and try to launch. If all good -- you can put some of your config files back (not too many, so that it can be detected which one is causing the problems) and try again. If works -- next batch of files.

4) I also recommend to look into idea.log file in .WebIde10\system\log\ folder -- it may give some hints.

0
Comment actions Permalink

Bazzik wrote:

Hi Keith,

I think it is your profile (I mean -- PhpStorm config).

1) Have you recently installed or upgraded any plugins? If so -- remove them. Even if you have not -- try removing them (back up first).

2) Removing .WebIde10\system folder (where all indexes/caches/logs etc are stored) may also help.

3) I would recommend back up PhpStorm config (C:\Users\USERNAME\.WebIde10\config), then delete it completely and try to launch. If all good -- you can put some of your config files back (not too many, so that it can be detected which one is causing the problems) and try again. If works -- next batch of files.

4) I also recommend to look into idea.log file in .WebIde10\system\log\ folder -- it may give some hints.

1) No, no new plugins (we don't use anything but the standard PHPStorm)

2 & 3) Tried that, removed the .WedIde10 directory, no effect

3) Looked in the log directory and it does not appear that it's even getting far enough to log anything at all

So, I logged in as another user (Windows 7), and it worked fine. Somethings corrupt in my Windows profile. Rebuilding it now. Ugh      :(

0
Comment actions Permalink

I had the same problem on the same day so perhaps it relates to a Windows update.  (Edit - ignore that, my problem happened on January 17th, 2017 not 2016).  

I renamed C:\Users\USERNAME\.PhpStorm2016.3 to something else and it then started and allowed me to import my settings, which seems to have worked.  I hope this helps others as this is much easier than rebuilding my Windows profile.

12
Comment actions Permalink

thanks Elric!  your tip worked for me.

1
Comment actions Permalink

Thank you @Elric you saved my day !!

0
Comment actions Permalink

Elric - thank you so much for sharing your solution.  It worked perfectly.  It was surprising to me that uninstalling and reinstalling PHPStorm did not remove this file, so your advice was very helpful.

0
Comment actions Permalink

Thanks Elric. I can confirm this worked for me as well.

0
Comment actions Permalink

Thanks Eric, that worked for me too....

0
Comment actions Permalink

I'm also here to thank Elric! Saved me probably a whole day dude!

0
Comment actions Permalink

I've been suffering from this for a month, and now I'm free. Thanks Elric!

0
Comment actions Permalink

It helps for the next start.

But if I close PHPStorm, I have to rename the config folder again to start PHPStorm.

The Index is lost and also the local history and it takes long time to rebuild the index. 

Something with the plugin manager seems wrong:

------------------------------------------------------ IDE STARTED ------------------------------------------------------
java.lang.reflect.InvocationTargetException
com.intellij.ide.plugins.PluginManager$StartupAbortedException: java.lang.reflect.InvocationTargetException
at com.intellij.ide.plugins.PluginManager.a(PluginManager.java:99)
at java.lang.Thread.run(Thread.java:745)
Caused by: java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at com.intellij.ide.plugins.PluginManager.a(PluginManager.java:96)
... 1 more
Caused by: java.lang.NoClassDefFoundError: Could not initialize class sun.util.calendar.ZoneInfoFile
at sun.util.calendar.ZoneInfo.getTimeZone(ZoneInfo.java:589)
at java.util.TimeZone.getTimeZone(TimeZone.java:560)
at java.util.TimeZone.getTimeZone(TimeZone.java:516)
at com.intellij.openapi.application.impl.ApplicationInfoImpl.a(ApplicationInfoImpl.java:951)
at com.intellij.openapi.application.impl.ApplicationInfoImpl.a(ApplicationInfoImpl.java:671)
at com.intellij.openapi.application.impl.ApplicationInfoImpl.<init>(ApplicationInfoImpl.java:222)
at com.intellij.openapi.application.impl.ApplicationInfoImpl.getShadowInstance(ApplicationInfoImpl.java:622)
at com.intellij.idea.StartupUtil.c(StartupUtil.java:365)
at com.intellij.idea.StartupUtil.prepareAndStart(StartupUtil.java:138)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at com.intellij.idea.MainImpl.start(MainImpl.java:42)
... 6 more
------------------------------------------------------ IDE SHUTDOWN ------------------------------------------------------

0
Comment actions Permalink

@J Straka 

  1. Any custom plugins?
  2. What's your OS?
  3. What Java/JDK/JRE version do you use (check "About" screen in PhpStorm)?
  4. How did you install PhpStorm?

So far it looks like Java-related issue (e.g. wrong platform or corrupted installation).

2
Comment actions Permalink

@Elric you saved my day thanks, i renamed my user profiles at :

C:\Users\USERNAME\.PhpStorm2016.

 restarted and  as promted to import,  I imported the non starting profile, and worked again .

 

Thanks a lot @Elric

0

Please sign in to leave a comment.