Fatal error initializing class com.intellij.openapi...

I occassionally get this error when starting phpStorm.  Any suggestions on how to fix this or do I have to live with it? Below are images of the error message dialogs I receive.  I have to kill phpStorm via the task manager and then restart it.  I am running this on XP 32-bit updated to the most recent patches.

http://img152.imageshack.us/img152/1353/errormessages.gif

4 comments
Comment actions Permalink

1) Remove all plugins
2) Try latest 2.0 EAP build

0
Comment actions Permalink

Alexey,

Thank you for the response.  Before I do that I'd like to "backup" my editor Color & Font settings as well as the IDE settings.  How do I go about doing this?  The reason I ask is I recently uninstalled Webstorm as phpStorm does everything I need.  When I did it erased my editor Color & Font settings (as well as all of my other IDE settings) much to my dismay.  It took me awhile to get it back the way I like and I don't want to go through that again.

Thanks for the help.

0
Comment actions Permalink

Hi Robert,

The easiest way is to use "File | Export Settings ...".

If you want to backup all files (whole profile), then file location depends on your OS. For Windows 7 the path will be: C:\Users\USERNAME\.WebIde10\config

When I did it erased my editor Color & Font settings (as well as all of my other IDE settings) much to my dismay.

That is because you have selected (or forgot to unselect) such option when you run uninstaller.

0
Comment actions Permalink

Just wanted to let you know I've upgraded to 2.0.  One error on start up so far in the first dozen times I've used it, I didn't record it but haven't had any since. If I still have issues I'll post here again.

0

Please sign in to leave a comment.