Don't Run Multiple IDEs

I've been reviewing PhpStorm (awesome, by the way) for our company and was tearing my hair out trying to get xdebug working on Ubuntu - it kept saying over and over that port 9000 was busy. Maybe some other bright mind would have jumped to this conclusion right away but I finally did a netstat -pant and saw that Zend Studio was already listening on port 9000. All well and good, except that I was not currently debugging with Zend Studio!

So this is a bit of knowledge contribution: if you have Zend Studio even RUNNING (and I'm sure its the same with Eclipse PDT) , it will completely take over port 9000. Only run one IDE at a time.

2 comments

Yea, we've seen that too. We don't Debug in ZS, so we just changed the port.

0

Hello Jarrod,

Thanks for sharing!

Only run one IDE at a time.

9000 is default XDebug port. You can try to change XDebug port setting(to 9001 e.g.) in Zend Studio in order to avoid conflict.

0

Please sign in to leave a comment.