Why is incorrect PHP version syntax not flagged?

Ok, I normally develop for 5.3 servers, but I have a few that are 5.2 (not mine, can't update them.) If in options, under PHP, then home is set to a 5.2 directory and shows up as the correct version, but this is not flagged as an error. Why not?

$sID           = $sID ?: "Dirty";

2 comments
Comment actions Permalink

PhpStorm officially supports 5.3 only (some link to back up these words)

0
Comment actions Permalink

Why is that? Seeing that PHP still supports 5.2 (I wish they didn't, but it's a fact, I use a very large web hosting company that still runs 5.2)

0

Please sign in to leave a comment.