Maximizing window does not maximize it

HI!

It happens pretty often, when I maximize the WebStorm window (clicking on WebStorm on the taskbar), it maximizes and then immediately goes to the non-maximized size (in my case full height and about 60% screen width).
This happens in 1.0.2 and 2.0 EA. Is this a known bug?

Running JDK 1.6.0_22 on Gentoo Linux.

Thanks!

Thomas

9 comments
Comment actions Permalink

Well, we do test UI on ubuntu linux only and get no problems like this. Users actually use various Linux builds (Suse Linux, kUbuntu, etc.) and never report such a problem we consider this to be either your OS, 3rd-party software or window manager problem. Some exotic window managers are known to be not compatible with our IDE. These problems shold be rised with their respective developers.

0
Comment actions Permalink

In the meantime, I got the same problem with NetBeans.

Maybe it is the combination of a specific JDK version (6.0u22 in my case) and KDE4.

0
Comment actions Permalink

I have the same problem on ubuntu with the ide phpstorm. Some one still facing the issue ?

Regards,

Louis

0
Comment actions Permalink

Louis, what version of PhpStorm/WebStorm and Ubuntu do you have installed?

0
Comment actions Permalink

Hello,

I'm using kubuntu 18.10.

Here the information of phpstorm :

PhpStorm 2018.3.4
Build #PS-183.5429.47, built on February 8, 2019
Licensed to Louis THOMAS
Subscription is active until February 11, 2020
For educational use only.
JRE: 1.8.0_152-release-1343-b26 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.17.19-041719-generic

 

0
Comment actions Permalink

Could you please clarify what the reproduction steps are exactly? I tried clicking the taskbar icon as described in the initial post, it doesn't seem to maximize the window.

Clicking the window header seems to do the trick OK: http://recordit.co/F8SQtjfrNG

0
Comment actions Permalink

Thanks for trying to help me.

A video with the issue : https://www.useloom.com/share/faf5f59e731b40f6bc3bb96a7411740b

I saw you tried on kubuntu. I'm gonna try to reinstall it ! It only happened with Phpstorm application.

0
Comment actions Permalink

Ah, I see, it's different to what OP described. I think it's this one: https://youtrack.jetbrains.com/issue/IDEA-196425

Please install EAP and check if it's better there: https://www.jetbrains.com/phpstorm/eap/

0
Comment actions Permalink

This is the same issue and the solution with "suppress.focus.stealing" works like a charm thanks ;)

0

Please sign in to leave a comment.