Problem With Autocomplete - Some Workspaces Don't Work

We have a problem that sometimes this doesn't work for external libraries (folders in the include path.) Right now, I have two different branches on my machine that work, and one doesn't. On another machine, one of the branches that a user is using doesn't work, that on mine it does. How do we fix this?

8 comments

Here's the problem. This entry is missing from .iml. How is this created?

    <orderEntry type="module-library">
      <library name="PHP 5.3.3">
        <CLASSES>
          <root url="file://C:/PHP/PEAR" />
          <root url="file://$MODULE_DIR$/../3rd Party Apps/fckeditor" />
          <root url="file://$MODULE_DIR$/../3rd Party Apps/zf/library" />
        </CLASSES>
        <SOURCES />
      </library>
    </orderEntry>

0

This is managed by Settings | PHP | include paths table...
does content on both machines is the same?..

0

I thought so, and yes, but they have different contents in this file.

0

Probably some bug in library processing code.. Will investigate. Can you try to clear table, APPLY settings and than reimport/fill table again?...

0

We tried that. It only works if we delete the .idea folder, and re-create it.

0

Thanks for rapid feedback. We'll investigate the problem. No workaround except re-creation of project is available now.

0

As I understand .idea folder is part of VCS (copied from master to local pc)? Otherwise this may be related (when creating huch entries manually): http://youtrack.jetbrains.net/issue/WI-3602?projectKey=WI

0

Please sign in to leave a comment.