change fonts


I might have missed something here ....but i have installed Pragmata, which i wanted to use as my editor font
but when i go to settings and Fonts and then try to choose / find it, its not listed (yes i have unchecked the use monospace fonts)

Any ideas ?
What is phpstorm looking for ?, do i have to install it elsewhere or how can i solve this ?



OS version?/JDK version?/IDE version?/font type?



Windows 7
JDK - no idea
IDE 1.02
Font type - pragmata ttf

Installs / is usuable in EditPlus, and Zend without a problem btw
just doesn't even show up as a choice by PHP Storm


Maybe it isn't monospaced but you ticked "Show only monospaced" in select font dialog?


as i mentioned in my initial post......(yes i have unchecked the use monospace fonts)


For JDK -- see Help | About.
Windows 7 -- x32 or x64 ?

I assume you have already restarted after installing font (it is absolutely not required .. but) and when you go to Control Panel\All Control Panel Items\Fonts the font is not displayed faded (if you switch to Tiles or Details view you see "Show" not "Hide" next to font name).

I had no issues when I was installing Consolas font, but that was like a week or two before installing PhpStorm for first time...

You can try and tell PhpStorm which font to use directly (by editing config file), but that may not work if PhpStorm cannot see that font. Any way ...
0) Close PhpStorm if open.
1) Go to .WebIde10\config\colors\ folder (should be in C:\Users\[put-your-user-name-here]\.WebIde10\config\colors
2) Open the color scheme you use (Same name as in Settings | Editor | Colors & Fonts | Font -- must be anything except Default). Just do not forget to make backup of it in case anything will go wrong.
3) Edit this line: <option name="EDITOR_FONT_NAME" value="Consolas" /> -- replace Consolas by your font name.
4) Save and start PhpStorm.


could be the font setup.  I tried adding an .otf font type to my system to use in phpstorm.  Didnt work.  PhpStorm couldnt see it.  The rest of the system could, but it didnt display in PhpStorm.

Try running your font though here: (free converter to .ttf font-type)

To get a different structure to your .ttf file and see if it appears then.


Sorry, still no idea. Usually it works. The only thing that comes to my mind tht this is some JDK problem... Did you tried to restart IDE/OS after font installation?...

Zend is based on Eclipse and uses native code for this... You may try to check font with Netbeans/JEdit/MuCommander - these are pure java apps, just as PhpStorm is.


Suggestion: Add a "Flag as spam" link to the posts. ^


Please sign in to leave a comment.