(Un)Indenting block of code with (shift-)TAB not working

I don't see this as issue in the bug tracker, so I think it is just down to me not finding a setting.

If I select a block of code and press TAB, it is replaced by a tab instead of indented.
Shift-tab does nothing.

I have this in all file types. Anyone have a clue?

3 comments

Hi Peter,

Possibly the Tab key is not linked to correct editor action. Which keymap do you use?

1) Settings | Keymap
2) Click on "Filter" icon (next to search box)
3) Press Tab in that popup -- and it will search for any actions that are linked to this shurtcut. The same for Shift+Tab

Tab should be linked to Main Menu | Edit | Indent Selection and Shift+Tab to Main Menu | Edit | Unindent Selection.

0

Ah, ok, I am using the 'NetBeans 6.5' Keymap settings. This does not have the tab/shift-tab assigned to those menu items (should do though).

0

Please sign in to leave a comment.