IDE freezes

Hi

I would like to know if it's possible to stop this background thingy php storm is doing esp. at the moment the interface gets focus, which is the moment i want a responsive interface.
3-11-2010 13-18-09.png
It's most annoying to see that by the end of a day's work the right number will be around 350, it just keeps growing and growing, but it never seems to be enough. Also: why does it wait to do this proces until i actually need the interface?

Regards
Michaël

11 comments
Comment actions Permalink

How large is the file you are working in (lines)?

0
Comment actions Permalink

some 500 over 6 different files but it also happens when there's hardly anything open. So, do you know what's happening in the right bottom corner?

0
Comment actions Permalink

Well, those files are pretty small, so that's not the issue. I have problems when the files get over 4000 lines, so I split them up.

That's the heap. Mine's using 215M of 483M right now, and is running pretty good.

Sounds like you have some other issues. Do you have virus scanner that scans the PHPStorm cache files? The Project files?

0
Comment actions Permalink

But sometimes there's no problem at all. If it was the virus scanner, wouldn't that be allways?
I just thought: could the problem be that the files are all on a network share?
Still, the problem only occurs when there's allmost no heap space left. You can see it hit rock bottom and then after this, it will take bigger heap space. Then everything works fine until the next time it runs out of heap space. Which is allway when the IDE has been in the background for some time and it gets focus. Is there a way to create a bigger heap space in advance?

Thanks for your reply!
Michaël

0
Comment actions Permalink

Can you give me the specs on your machine? OS? If on Windows, one thing I found that helped when using Netbeans on share was to to map the drive and the make it available via Offline Files. Still, is your machine taxed otherwise?

I'm running Windows 7 x64, 4GB RAM, RAID 0 and it runs pretty solid, with the occasional slowdown.

0
Comment actions Permalink

OK I'd say you got a pretty big machine there!  I´m on a 3 year old laptop with W-XP and 1.5 G internal memory :8} There's no other distractions for the machine but i usualy have a couple of programs open like phpstorm, one or two browsers, ssh client, svn client (java app!), mysql client. the usual development stuff.
I'll try your offline-files-tip, that'll be friday, but I'll get back here to report. On my home laptop things run a bit smoother (only local files), so maybe we're on the right track here.

Thanks for your help so far!

Michaël

0
Comment actions Permalink

Wait, are you working over VPN or some sort of remote access, or is a network share on a LAN?

0
Comment actions Permalink

No, it's on a LAN. My 'local' working copy is actually on a server in our LAN. It's mapped to a local windows drive (though it's a linux server, so there's samba in there as well). It's a big network but it's fast (i work for a university).

0
Comment actions Permalink

Sorry that I'm a bit late on this thread - we're quite busy on the PhpStorm booth on ZendCon'10.

The problem is that IDE *requires* that you have a local copy and under that I mean one residing on your HDD.

You should use "New project from existing files" wizard to create one and it will set up a auto-sync for you so all files will be transparently updated on remote location.

0
Comment actions Permalink

Wow that's a great feature for me! B-)
I'll try this friday and report back.

0
Comment actions Permalink

OK, it works! I had to switch auto-sync on myself in settings-deployment-options.
It does give me a much more responsive IDE of course.
Thanks for the help guys!

0

Please sign in to leave a comment.