EAP 98.191 broke PhpStorm for me

Hi guys,

I have been evaluating PhpStorm for about a week now, and I love using it so far. I want to recommend it to my office to replace our current IDE (Dreamweaver), but I am having a few problems.

I started using version 1.0.2 and was extremely happy with it. However, the lack of word wrapping (or soft wrapping) was making it hard to do content changes to existing webpages. I upgraded myself to the EAP 45-day trial, starting with version 98.145, which worked good.

Today I upgraded to 98.191 and I have been having a lot of problems. When I installed the editor and booted it up, it came up with an IDE error that I submitted to JetBrains, in order to clear the error, I had to "Disable PHP". Now that php is "Disabled" I no longer have the file association in the editor for PHP and the IDE does not recognize PHP files when I try to open them. Also, in this build, I cannot open the File->Settings window at all.

I uninstalled both 98.191 and 98.145 and installed 1.0.2 again but the PHP file association is still missing and the editor is unable to open php files.

Can you help me restore the editor to a working state please?

Thank you in advance,
Andrew

9 comments

I just uninstalled 1.0.2 and reinstalled 98.191 again. I still cannot open the Settings menu and PHP files are still unrecognized. Also this version is unable to see Mapped Network Drives when browsing for project files!

0

I managed to get the editor working again, by uninstalling 1.0.2, manually deleting the JetBrains folder, and reinstalling EAP 98.145. Should I avoid the 98.191 build alltogether!?

0

Well, you've got to follow some rules to have a good experience with Early Access Preview builds:

1) You should backup your settings when installing new build. Also, settings are NOT backward compatible with earlier builds. Remove completely and restore from backup on downgrade.
2) Always perform File|Invalidate indxes after update

Then, I've got some questions:
Why did you pushed "Disable PHP" button? What did you expected to happen? have you submitted the error report? How do you expect PHP support to work if you "disabled" it? Please reenable it at Settings | Plugins.

How to go reset settings:
Settings saved under USER_HOME/.WebIDE10 - You need to remove the folder to have a fresh start on 1.0.x any other build.

Opening shared folders is officially unsupported for both 1.0.x and 2.x - you should use "new project from existing files wizard"
Anyway, the problem is in the way windows hadles installer user rights - just restart IDE once to fix it.

0

Hi Alexey,

Thanks for the quick help, it is much appreciated.

I don't have File->Invalidate Indexes, I have File->Invalidate Caches, although I assume thats what you meant.

I hit the Disable PHP button because the error help occuring and my only options were "Send Report", "Disable PHP", and "Close". The first time the error came up was when I tried to go into the Settings menu. I submitted it the first time it happened, and after it happened again, I hit Disable PHP to see if it would let me into the Settings menu.

I am going to uninstall 98.145, remove that settings folder, install 98.191 and use File->Invalidate Caches to see if I can get it working. Will let you know how it goes. Thanks again for the help!

0

If you'll be unable to set up 98.191 properly or get the Settings errors again - post right here..

0

Hi Alexey,

I followed all the steps I outlined above and things appear to be OK.

I was unable to get into the Settings menu right away (with no projects open). I opened after installing, Invalidated Caches, restarted the IDE the see network drives and was still unable to get into the Settings menu.

I then added a project using New Project From Existing Files... and am now able to get into the Setttings menu. It seems that you can only open the Settings menu if a project is open?

0

I am not able to bring up the Setting menu when project is closed as well.
Only when I open a project the setting menu will come up.
(Windows 7 x64, phpStorm EAP 98.191)

0

I can confirm this issues (same OS.)

0

Reproduces for me too. Will investigate.

UPDATE: well, its fixed for next EAP

0

Please sign in to leave a comment.