Configutation of the Debugger in 'PHP on Server' mode

I have never been able to figure out how to set up mappings in the PHP debugger. Can anyone  help???

I'm running apache2 locally. The doc root (per httpd.conf) is /opt/local/apache2/docs/portal/ which looks like this.
$ ls -al
total 72
drwxrwxrwx@ 11 root  admin   374 Sep  3 09:10 .
drwxrwxrwx@  4 root  admin   136 Jul 21 15:31 ..
lrwxr-xr-x@  1 root  admin    67 Jul 13 17:39 .htaccess -> /usr/local/terriblyclever_portal_v2/TCFramework/bootstrap/.htaccess
lrwxr-xr-x@  1 root  admin    70 Jul 13 17:40 application.php -> /usr/local/terriblyclever_portal_v2/application/config/application.php
lrwxr-xr-x@  1 root  admin    61 Jul 13 17:41 assets -> /usr/local/terriblyclever_portal_v2/application/views/assets/
lrwxr-xr-x@  1 root  admin    71 Jul 13 17:39 bootstrap.php -> /usr/local/terriblyclever_portal_v2/TCFramework/bootstrap/bootstrap.php
lrwxr-xr-x   1 root  admin    20 Aug 30 14:38 coverage -> /tmp/portal/coverage
-rw-r--r--@  1 root  admin  1078 Aug  5 11:02 favicon.ico
lrwxr-xr-x@  1 root  admin    75 Jul 13 17:40 host.php -> /usr/local/terriblyclever_portal_v2/application/config/deploy/localhost.php
-rw-r--r--   1 root  admin    17 Sep  3 09:10 phpinfo.php
-rw-r--r--@  1 root  admin    14 Jul 26 19:31 test.php
$

My httpd.conf re-routes all php requests to bootstrap.php

My project root is /usr/local/portal_repo/trunk.I suspect that someplace I need to be telling PHPStorm the location of the apache doc root but when I enter it, I get an error about how it is 'not in project'

When I try to start a 'PHP on Server' debug session, I get this:
debugimage4.jpg
Here are the config settings that worked until PS-98.108.

debugimage1.jpg
debugimage2.jpg
debugimage3.jpg

4 comments

Hi Jim,

Try the latest EAP build (PS-98.145) -- just published. It fixed debugger issues (at least those that were affecting my setup). Then we can look for the rest.

0

PS-98.145 does indeed address many of the Debugging issues that cropped into PS-98.108, I'm still having the issue (Validation Failed) that I describe here.

0

I do not really know why that "Validate Xdebug configuration before debug" option is required for each run. I mean -- yes -- for first debug launch .. or after you made some Xdebug configuration changes .. or after you have updated Xdebug module. But after that -- do you really need this if you perfectly know that Xdebug is there, it's properly configured and working ??

I personnaly have this turned off all the time (except once -- shortly after they have introduced this option (fr testing purposes) -- but debug was working fine even without it in v1 so ...)

Now, back to that "validation failed" message. As far as I remember, if that option is turned on, then before each debug run PhpStorm will put special file into the root folder of your site (you can see that on your first screenshot -- it starts with "PhpStorm-", then some random GUID (http://en.wikipedia.org/wiki/Globally_Unique_Identifier) and will delete it after validation (successful or not). Now, if I understood correctly, your project root and website root are completely different folders, right? So PhpStorm puts the file in one place/directory, but apache looks for it in another directory (when PhpStorm tries to execute that script). This may be the root of the problem.

What I'm trying to say here -- try to debug with that option unchecked/turned off. In my opinion this should do the job.

0

Please sign in to leave a comment.