Mac: Every PhpStorm startup my firewall ask me:

Hi,

on every PhpStorm startup my firewall ask me for allowing incoming network connections for PhpStorm - and i always say ok!
I add the PhpStorm_nnnn.app as an allowed application but the next start my mac ask again.

How can i stop this behaviour?

Bye, Dumbledore

5 comments
Comment actions Permalink

No ideas. IDE is a normal java application. I think you should consult OS X forums.

0
Comment actions Permalink

Maybe sometime you restart IDE from application (for example, menu "Invalidate caches") - in this case main process is "restarter", which isn't "trusted" and processes, started by "restarter", aren't trusted too.

0
Comment actions Permalink

Same problem here

0
Comment actions Permalink

It looks like its a problem related to the version of JavaApplicationStub.

This happens with some other java based applictions.


This explains how to fix the problem temporary, though I did't found the JavaApplicationStub file..
http://help.infinitekind.com/discussions/switching-to-moneydance-from-microsoft-money/49-firewall-issue-with-max-os-x-105


For a permanent solution, Jetbrains could use some other version of JavaApplicationStub or probably the best option is to signing the application code so that mac firewall clears the application like guys from moneydance did.

0

Please sign in to leave a comment.