Cannot Get XDebug to Connect

I don't have any problems making this work with Netbeans, but PHPStorm will not connect XDebug. It just says waiting for XDebug connection on port 9100.

Here are my php.ini settings:

[xdebug]
zend_extension="c:/php/ext/php_xdebug-2.1.0-5.3-vc9-nts.dll"
xdebug.remote_enable=1
xdebug.remote_host=127.0.0.1
xdebug.remote_port=9100
xdebug.remote_handler=dbgp
;xdebug.remote_autostart=1
;xdebug.idekey=PhpStorm1
xdebug.profiler_enable=1
xdebug.profiler_output_name=cachegrind.out.%s
xdebug.profiler_output_dir=c:\xdebug_prof

And my PHPStorm debug config:

phpstorm_debug_config.JPG

5 comments

Hello Keith,

If you select 'Validate Xdebug configuration before debug' checkbox and run it again, will any message be shown?

Regards,
Kirill

0

Actually, I've gotten past that. Now, it just acts like it's going to connect and then says Disconnected and nothing happens. I have Validate checked now and it works fines. I just can't get PHPStorm to actually connect to a debug session.

0

Sorry, I'm confused. I was testing the console. That does appear to be working now. What I really need is to debug on server (localhost), and it works fine on Netbeans, but I can't get the configuration correct on PHPStorm. I don't understand all this path mapping. In Netbeans, I don't have to map anything.

0

Ok, well, I got that working, but it says

Warning: Web path '75_steps.php' is not mapped. PHP breakpoints may not work for such paths.

what does that mean and how do I fix it?

0

lol

everytime I post here, then I immediately figure it out for myself. I still don't understand the purpose of mapping, but I added a mppaing for / in Deployment and the warning went away.

0

Please sign in to leave a comment.