Several questions

Hello people, I've only started using phpstorm for a while now, i love it but some things are really annoying me, I'm sure there are answers so here goes:

  • Syntax highlighting is not working for PHP files and I cant figure out how to make it work.
  • I use ctrl+shift+r "open resouce" in eclipse all the time, is there something similar in phpstorm?
  • There is no "save as"? What is the alternative?
  • The menu to open file with browser keeps disappearing
  • How do you upgrade? do you have to uninstall and then reinstall?


Thanks for any help with these

6 comments

Hi badger,

1) Well ... never had such problem with any php file. Can you please provide a full example of such file (not just part of the file, but the whole file) ?
2) Never used it -- cannot advice here
3) In editor: simply press F5 (or Menu -> Refactor -> Copy). In Project view -- the same (right click on desired file -> Refactor -> Copy)
4) "Alt+F2" or Menu -> View -> Web Preview  (but I never used this feature myself, so cannot guarantee 100% correctness)
5) Unfortunately Yes. See this ticked: http://youtrack.jetbrains.net/issue/WI-2937?projectKey=WI

Regards,
Andriy

0

Thanks Andriy,

Regarding the syntax highlighting not working, I've tried lots of files, even a simple hello world doesn't work.

Here is a basic file example:

<?php
    $link = mysql_connect("localhost", "mysql_user", "mysql_password")
        or die("Could not connect: " . mysql_error());
    print ("Connected successfully");
    mysql_close($link);
?>



I just get it all in dark blue
0
  1. Are you sure that you've downloaded PhpStorm and not the WebStorm?
  2. Goto|File ? I'm not familiar with eclipse.
  3. Copy-Paste on Project view. Related request http://youtrack.jetbrains.net/issue/WI-842
  4. Please provide better description
  5. Yes. Related request http://youtrack.jetbrains.net/issue/WI-2937
0

Hi, thanks for your reply,

1. yes i am sure, phpstorm 1.0.1
2. Thanks goto file seems to be similar :)
3. thanks
4. it looks like alt+f2 does it
5. thanks

0

Well, than check that PHP plugin enabled in Settings|Plugins and that your file extension is mapped correctly at Settings|File types.

BTW, please upgrade to 1.0.2 until requesting any further help.

0

ahhh thats much better, it was assigned incorrectly for some reason, possibly because I was using webstorm before I decided to go for phpstorm.

Thanks for your help

0

Please sign in to leave a comment.