How to turn off "Language Injections" option?

After installing EAP 96.1224 in all installed versions of PhpStorm (1.0.2, 96.1130, 96.1224 @win7 32) can not be turned off language injection "php: <html>".
Each run of IDE i should turn it off, and it becomes really annoying. Is there way to turn off option "Language injection"? Maybe some register key?

11 comments

IDE settings are NOT compatible between EAP's (and releases). You should back them up.

Anyway - just DELETE everything on injection page and restart IDE, so defaults will be imported. Than, turn unndesired ones off.

0

neuro159 wrote:

IDE settings are NOT compatible between EAP's (and releases).

I don't care about that. I'm talking about other.

neuro159 wrote:

Anyway - just DELETE everything on injection page and restart IDE, so defaults will be imported. Than, turn unndesired ones off.

No, it doesn't work.
After this, i have "default-set", and again i can't check off "php: <html>". Actually it checking off, but after restart "new" string appears:
screenshot: http://img148.imageshack.us/img148/2136/111tk.png



Attachment(s):
111.png
0

Well, injections are stored in settings - and will be affected by build incompatibility. So you have to care.

Anyway, I was able to reproduce the problem.

As a workaround you may try to remove NEWLINES from last two sections (so they look like preivous ones) of
plugins\php\lib\php.jar\resources\phpInjections.xml

0

Thank you very much.
It works!

0

For 98.21: in this XML-file in line 26 column 21 extra space.

0

Where is that file? I can't find it.

0

\PhpStorm 98.21\plugins\php\lib\php.jar - open this file by some archivator (jar-file is zip-archive), you'll see list of directories, find "resources", phpInjections.xml - is the xml file which you want.

0

Ugh, tried it but causes PHPStorm to crash. Do i need to use a specific level of compression or anything?

0

Take changed file. I didn't touch nothing except that wrong space.



Attachment(s):
php.jar
0

Sorry for not fixing it completely this time.
And thanks for taking care of it, OZ.
We'll make it less picky about formatting at some point..

0

Please sign in to leave a comment.