can't run webide after jdk update

Hi. I'm just update JDK to 6u21. Now I can't run PhpStorm.
He is crashed with message:
Java HotSpot(TM) 64-Bit Server VM (build 17.0-b16, mixed mode)
YourKit Java Profiler 8.0.22 cannot start: latest Java 7 builds cannot be profiled anymore with this version of the profiler. To profile with Java 7, use YourKit Java Profiler 9.0 - http://www.yourkit.com/eap

5 comments
Comment actions Permalink

Hello Dmitry,

Try disabling profiling agent. You can't take the performance and memory snapshots, but you can use all the rest application features.

Open <IDEA>\bin\idea.exe.vmoptions file (Windows) or <IDEA>/bin/idea.vmoptions (Linux) with text editor.
Remove the line:

-agentlib:yjpagent=...

Try to start PhpStorm.

Regards,
Kirill

0
Comment actions Permalink

Thanks for reply, Kirill.
I don't see file <IDEA>/bin/idea.vmoptions maybe <IDEA>/bin/webide.vmoptions? but this line (-agentlib...) is not there.


/opt/phpstorm/bin/$ cat webide.vmoptions

-Xms32m

-Xmx500m

-XX:MaxPermSize=150m

-ea

-Didea.platform.prefix=PhpStorm

0
Comment actions Permalink

Linux builds pass this option in different way because of need to load proper version. Look for it inside bin/*.sh and remove entire -agentlib=.... parameter.
Alternatively you can download YourKit 9 and get proper .so from it.

0
Comment actions Permalink

It works. Thanks,  Alexey.

0

Please sign in to leave a comment.