libgcj: Error opening agent library.

Hi,

suddenly I can't start PhpStorm anymore:

ingmar@ingmar:~$ /usr/share/PhpStorm/bin/webide.sh
java version "1.5.0"
gij (GNU libgcj) version 4.3.2

Copyright (C) 2007 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
libgcj: Error opening agent library.
libgcj: couldn't create virtual machine
ingmar@ingmar:~$

What seems to be the problem? I tried various settings of LD_LIBRARY_PATH:

.:/usr/share/PhpStorm
.:/usr/share/PhpStorm/
.:/usr/share/PhpStorm/bin
.:/usr/share/PhpStorm/bin/

None of them worked.

Thanks,
  Ingmar

2 comments
Comment actions Permalink

You need to switch to SUN JDK 1.6.

0

Please sign in to leave a comment.