phpStorm sftp saves empty file

Hi ...
for some reason it started to save empty file to sftp location ...

i used to do it all the time .... i open it like regular direcoty `/.sftp/(host)/file/path/directory

i have fedora 13 sun jdk ....

It saves fine on local disk but the .sftp is messed up ....

7 comments

i have made a mistake it is located in `/.gvfs/(host)

i have mounted it already .. any other editor like gedit works fine

phpStorm 95.150 ....

started to do so after i installed sun JDK .. before it was running on openJDK ..... VERY VERY SLOW .... but worked .... this might be coincedend .... also i have updated from fedora 12 to fedora 13 .... but i worked in fedora 13 i think before it started to do so .. maybe not .... i can't undo the changes .... i tryed to switch back to openJDK but no efect also tried the older version of phpStorm .. same thing ... this should be confirmed as a bug or not ..... it is very inconvinient ..... i almost lost my source code with 2000 lines in it

0

I have managed to solve with with mounting a remote host with sshfs comand it worked like a charm

But still it worked before ... i don't maybe it is related to fedora 13 update..

0

Open JDK is not supported.
Also, we have no other similar reports so its probably related to you OS upgrade.

0

Thanks.....
I think it's a Fedora thing ..... too ...

on the fedora 12 i was using OpenJDK and it was a litle slower ....
now i have instaled sun JDK and WOW it RUNZZZZZZZ
I'm inpresed ...
Thanks for a great tool!!!!!!!!

0

Hello Asp3ctus,

Does the problem of empty file upload repeat?

Thanks,
Kirill

0

yes still dotn's work .. i have set by self a different way ...
Actually this will be a GOOD feature for phpStorm ...
insted of doing sftp uplaod .... you can use somethign called rsync .. i have set it up in a bash scritp and use it as external scritp ... the thing is it will update only changed fieles .. much better then wating for uploding the whole project ..... and if it is a live upload

welll i attached a screenrecorded with the problem for you to see

system is fedora 13 ... i can confirm that fedora 12 is fine ... because i have fedora 12 on dif computor and it is fine!!!



Attachment(s):
phpstorm.ogg
0

Hi Asp3ctus,

Can you please provide the logs according to the steps at http://www.jetbrains.net/devnet/docs/DOC-1202 and take a snapshot of File | Settings | Deployment | Options pane?

the thing is it will update only changed fieles


Try unchecking 'Overwrite up-to-date files' at the above-mentioned page, PhpStorm should deploy only changed files.

Thanks,
Kirill

0

Please sign in to leave a comment.