Still having problems with remote debugging...

I have co-workers that have successfully setup their machines to do remote debugging on the development machines using eclipse.  However, I am unable to get phpStorm remote debugging to work.

I have verified that all the appropriate .htaccess changes have been made to enable remote debugging.  I have checked the validate xDebug configuration and it goes through scuessfully.  The problem is that none of the breakpoints are caught.  I have tried multiple project configurations with no luck.

I've also made sure everything in this thread has been setup:
- http://www.jetbrains.net/devnet/thread/287502;jsessionid=0BDD462D2D705A6199CB4D5285718485?tstart=0

I am at a loss here as to what else to do.  The only difference I can see between our machines is phpStorm requires an IDE key whereas eclipse doesn't seem to require one.  Other than that everything looks the same.

As a side note the UI for setting up remote debugging is EXTREMELY confusing.  Especially with no guide to follow.  I highly suggest you revisit this UI before launching this product.

I look forward to receiving help and I am happy to answer any questions.

Remote Server: linux
Local Machines: OS X (Snow Leopard)
phpStorm: 95.98

9 comments

Hello Chris,


Currently PhpStorm validates Xdebug setup for the root mapped directory. But if you're using htaccess files, you may have configured Xdebug differently for the directory where your PHP page resides, but validation phase may miss this. This is somewhat we'll have to fix.

If that's not your case, I have to look at the logs to find the reason. Can you please take them?

1. open <PhpStorm installation directory>/bin/log.xml with a  text editor
2. scroll to the bottom, add the following lines  before <root> tag:

  <category name="com.jetbrains.php.debug">
    <priority value="DEBUG"/>
</category>


3. Restart PhpStorm
4. try to start  debugging
5. Attach the log file found at ~/Library/Caches/WebIde10/log/idea.log

The only difference I can see between our machines is phpStorm requires an IDE key whereas eclipse doesn't seem to require one.  Other than that everything looks the same.

You can safely choose 'Open web page in browser' option if you're not going to launch the script manually, so that you don't care about ide key.

Thanks,
Kirill

0

I have a single .htaccess file in the root directory that sets up the debugging.  I have attached the log file you requested.  Just a note, there are lots of logs file in this directory, and I only included the base idea.log.  Please let me know if this does not contain the information you need.

Edit: Also I wanted to let you know, I have successfully setup Eclipse with remote debugging on my machine.



Attachment(s):
idea.log.zip
0

Chris,

there are lots of logs file in this directory, and I only included the base idea.log.

Logs are rolling, so usually you need just idea.log (it's the latest one).

From the log I see that server path mappings may be set incorrectly.
Please open your run configuration dialog, click 'Server path mappings' button and remove all the entries. If this does not help, please provide the logs again.

Thanks,
Kirill

0

There were already no entries in that dialog.

0

Hello Chris,

One more question: which PHP version are you using?

Thanks,
Kirill

0

Hello Chris,

Thanks for your help, we've found the problem: http://youtrack.jetbrains.net/issue/WI-1884. It will be fixed in the next EAP build. You need to use a workaround for now.

Regards,
Kirill

0

Looks like it worked!  Thanks a bunch!

0

Please sign in to leave a comment.