PHP debugger doesn't stop

Hi,

I have problem with PHP debugging in WebIDE with xdebug. I have:

1. a project configured with "break at the first line"
2. when start debugging, a new page started in Firefox: http://localhost/php/phpinfo.php?XDEBUG_SESSION_START=WebIDE1
3. in WebIDE, there is "Waiting for connection on port 9000 with ide key "WebIDE1"

But it doesn't stop at the any of my breakpoints of the first line.

I am attaching the log here. Can you please help??? Thanks a lot in advance!



Attachment(s):
idea1.log.zip
7 comments

I found out. I was using xdebug 5.3 version, while my PHP was 5.2.8. So when I switched to xdebug 5.2 it works.

0

Hi,

I'm trying to get debugging to work with xdebug also and have the same problem of it just sitting with Waiting for connection on port 9000 with ide key "WebIDE1". (maybe if it receives a connection with a different key it would be good to see that something is going on?)
I'm using the latest version of xampp (1.7.3) on windows, I assume as xdebug came in the xampp bundle that it's the right version.
Would you be able to share any php.ini related settings that I need to get this working, is there anything else that I can work through to try and make this work?

Many thanks,

Seb

0

Hello Sebastian,

First ensure that XDebug is installed: execute phpinfo() and check that output contains something like

with Xdebug v2.1.0-dev, Copyright (c) 2002-2008, by Derick Rethans

If it's not, refer to http://xdebug.org/docs/install#configure-php.

Then, check that your XDebug options in php.ini look like the following (more details on XDebug website):

xdebug.remote_enable=1
xdebug.remote_host=127.0.0.1
xdebug.remote_port=9000
xdebug.remote_handler=dbgp
xdebug.profiler_enable=0
xdebug.remote_log="c:\xdebug_log.txt" ; <-- this path usually points to some temporary folder

Regards,
Kirill

0

Thanks that works great.

For anyone else using XAMPP I've attached the required php.ini.

Thanks,

Seb



Attachment(s):
php.ini.zip
0

I've tried the same setup on another computer and it didn't work.
I found that for some reason php storm was listening on my external IP rather than on loop back. (i.e. 192.168.0.x) - it works if I change the php.ini to use this address.
Is there a setting somewhere that I can make it listen on loop back instead (i.e. 127.0.0.1)?

Thanks,

Seb

0

Hi Sebastian,

Currently PhpStorm listens on all network interfaces. It may be OS firewall is blocking packets going through the external interface. Can you please try debugging with firewall turned off?

Regards,
Kirill

0

Please sign in to leave a comment.