How to set the file cache settings of the IDE?

Let me explain. Suppose I am running a PHP web application on localhost, if I open the logs in Storm, they are not updated in the IDE, however if I open them with another text editor I see the updates as they are made by the server.

It seems that if another process updated a file that Storm has opened, Storm does not see the changes. Is there anyway to change that (maybe there is a timer parameter to change in the settings)?

Is it specific to Storm (I also bought RubyMine but did not notice this behaviour) or to all the IDEA derivatives?

6 comments

Your OS, and are there any symlinks in log path?

0

Hello Alexey,

The OS is Windows XP SP3 32bits and there are no symlinks in the log path. It also happens if I open a file with Storm, overwrite the file from FTP (outside of Storm); Storm still displays the stale version and other programs the new one.

0

FTP? looks like I can't understand about what caches you are talking about.

Please describe your project setup in full details. Include step-by-step details explicit expected and actual behavior description. Screenshots also can be helpful.

0

Hello Jamal,

Let me guess: are you talking that external changes to the project files (made by the program other  than Web IDE) do not appear in IDE? Please check you have 'Synchronize files on frame activation' option enabled at File | Settings | General pane. You may also try manual sync using 'Synchronize' action at the toolbar.

Regards,
Kirill

0

Hello Alexey,

The behaviour I get is as Kirill described. A file that is opened in Web IDE and modified by an external program (a log file, a file overwritten by FTP or a file opened with a different editor).

I'll try to post a reproducible way to get the same behaviour everytime.

0

Hello Kirill,

Exactly! The settings are okay. I'll learn to use synchronize more often

Regards,

Jamal

0

Please sign in to leave a comment.