Terminal Line Buffer increase

Hello I am new to the community, I am still working on setting up PHPStorm.  My current catch is the line buffer in the Terminal Plugin.  The line buffer holds about 100 ish lines.  Is there any way to increaese this line buffer?  I have been unable to find a setting for it.  Thanks for any directions.

Edit...
I am on a Mac

8 comments
Comment actions Permalink

Please try increasing

terminal.buffer.max.lines.count

value: Help/Find action, type 'registry', search the registry for the key above.
Note: this registry key is not available in PHPStorm 8, you need using PHPStorm 9 EAP
13
Comment actions Permalink

@Garrett you can open registry with ctrl+shift+A (Actions) -> type 'registry'

4
Comment actions Permalink

Cmd+shift+A   Then type 'registry'

It was the first entry

Thanks for the answers.

terminal.buffer.max.lines.count


3
Comment actions Permalink

Worked for WebStorm as well. 

For MAC users, as Garrett mentioned:

1. Cmd+shift+A
2. Type 'registry' in the search box
3. Click 'Registry...' to view registry details
4. Scroll down to 'terminal.buffer.max.lines.count' (or it may be near the top if it has been updated previously)
5. Click on the value in the Value column, enter new value (eg. '5000')
6. Click 'Close'

I had to restart WebStorm before the change worked.

Thanks for everyone's answers. 

3
Comment actions Permalink

Just follow the instructions given -- it's IDE's internal registry (hidden settings, if you wish) and not your OS.

1
Comment actions Permalink

perhaps something this important should be discoverable from the settings dialog. default is 1000 lines which is not enough for most developers

1
Comment actions Permalink

How would this work for Mac?  I don't think it has a registry.

0
Comment actions Permalink

FYI, when you're viewing the registry you can simply type "terminal.bu" to jump to that specific entry

0

Please sign in to leave a comment.