xDebug not works

Hi guys!

When I firstly installed PHPStorm xdebug work perfect. But after some time it stopped working.

My server xdebug configuration is

xdebug

xdebug support enabled
Version 2.1.0

Supported protocols Revision
DBGp - Common DeBuGger Protocol $Revision: 1.145 $

Directive Local Value Master Value
xdebug.auto_trace Off Off
xdebug.collect_assignments Off Off
xdebug.collect_includes On On
xdebug.collect_params 0 0
xdebug.collect_return Off Off
xdebug.collect_vars Off Off
xdebug.default_enable On On
xdebug.dump.COOKIE no value no value
xdebug.dump.ENV no value no value
xdebug.dump.FILES no value no value
xdebug.dump.GET no value no value
xdebug.dump.POST no value no value
xdebug.dump.REQUEST no value no value
xdebug.dump.SERVER no value no value
xdebug.dump.SESSION no value no value
xdebug.dump_globals On On
xdebug.dump_once On On
xdebug.dump_undefined Off Off
xdebug.extended_info On On
xdebug.file_link_format no value no value
xdebug.idekey dsnisarenko phpstorm
xdebug.manual_url http://www.php.net http://www.php.net
xdebug.max_nesting_level 100 100
xdebug.overload_var_dump On On
xdebug.profiler_aggregate Off Off
xdebug.profiler_append Off Off
xdebug.profiler_enable Off Off
xdebug.profiler_enable_trigger Off Off
xdebug.profiler_output_dir /tmp /tmp
xdebug.profiler_output_name cachegrind.out.%p cachegrind.out.%p
xdebug.remote_autostart Off Off
xdebug.remote_connect_back On On
xdebug.remote_cookie_expire_time 3600 3600
xdebug.remote_enable On On
xdebug.remote_handler dbgp dbgp
xdebug.remote_host localhost localhost
xdebug.remote_log no value no value
xdebug.remote_mode req req
xdebug.remote_port 9000 9000
xdebug.scream Off Off
xdebug.show_exception_trace Off Off
xdebug.show_local_vars Off Off
xdebug.show_mem_delta Off Off
xdebug.trace_format 0 0
xdebug.trace_options 0 0
xdebug.trace_output_dir /tmp /tmp
xdebug.trace_output_name trace.%c trace.%c
xdebug.var_display_max_children 128 128
xdebug.var_display_max_data 512 512
xdebug.var_display_max_depth 3 3



My IDE debugger configuration:
Снимок экрана 2013-05-18 в 10.03.15.png

Also I pressed 'Listen Debug Connections' button.

Should I enable something else to make it work?

3 comments

Hi there,

Two good articles, following which you should have it up and running:

My IDE debugger configuration:

This is not your "IDE debugger configuration". All what I see on screenshot is that you have set default values for one of the Run/Debug configurations (yep -- you do not even created one -- just set up defaults).

Also:

  • Please upgrade your xdebug to 2.2.1 or newer (it has some bugs fixed), although your version should still allow to at least initiate debug session)
  • You have your IDE key set to "phpstorm" on the screenshot .. but local value (for the session when you got your xdebug config) of xdebug.idekey = dsnisarenko
0

The problem been solved after removing deployment server from Preferences -> PHP -> Servers.
On the next debug run the new fresh deployment server mappings configuration been created. Works great.

0

That's not a "deployment server" -- it is a path mappings for debugger to work with (in case you are doing remote debug and/or do have symbolic links when everything is local).

But it is working now -- that's the main thing.

0

Please sign in to leave a comment.